1. AndySix

    AndySix Feb 23, 2019

    Posts
    62
    Likes
    78
    On my C45 I have the latest version of Wear OS (2.3) and systemversion "H".


    Before christmas I added a supported Mastercard into Google Pay and it worked fine the one time I got to test it for making a payment. I have not used my C45 for a few weeks now, but yesterday I was going to use it, but I noticed the Google Pay app was missing. I tried to redownload it from Google Play but it was only disabled so I just had to enable it. Now when I start the app it says "Can't use Google Pay: Google Pay hasn't launched in this location yet.Check again soon." That is simply not the case as I have used it before and my country is enrolled and I do have a supported credit card. Any of you experiencing the same issue?

    Just to be clear: I dont think this is a TAG Heuer issue, but a WearOS/App issue.

    Another thing - if I reboot or shutdown/turn on the watch - I need to enable Google Pay each time. It seems to disable itself. I would want to flush all data for the app if possible, but I have not figured out how do do that. I have not tried to reset the watch to factory (yet).
     
  2. Cecil

    Cecil Feb 24, 2019

    Posts
    78
    Likes
    188
    I hit similar issue. So I ask the dev
    , the official response from Google is that : pay of wear is is only available for certain countries, so googlG Disable it if it detected you are not located there.


    They are telling us to use pay for Androids (phone ) until wear pay is enable.
     
    AndySix likes this.
  3. AndySix

    AndySix Feb 24, 2019

    Posts
    62
    Likes
    78
    Unfortunately - it seems like you are right. My country is only supported on phone payments, not WearOS payments.
    Very strange and onfusing that they are supported different!

    Like this guy, I had already used it - but seems like it dissapeared in a recent update:
    https://support.google.com/wearos/thread/690888?hl=en